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System Overview

The Electronic Codebook (ECB) is a tool, which gives the user a vehicle to browse through the lists of
variables and variables’ information for datasets.  The ECB handles data in multiple files with the following
characteristics:

- Maximum record length = 1024 (an SPSS-PC 4.0 requirement)
- Multiple records per case
- Variable names (8 characters SAS/SPSS name unique within each file, but NOT necessarily unique in

different files.

The ECB performs the following:

* Presentation of a list of ALL variables
* For each variable, separate dialog boxes provide information such as:

- Frequencies, percentages, codes, and labels
- Descriptions

* Navigation through different sections and files
* On-line, hypertext help
* Full installation to adapt to different storage locations
* For user selected (tagged) variables, creation of

- SAS-PC code, including PROC FORMAT labeling
- SPSS for Windows 6.0 code
- IDs for merging modules automatically included in SAS/SPSS code
- ASCII text for printed codebook
- Microsoft Access databases
- Tag files

* Search for text
* Import of tag files
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The ECB Main Window

The ECB Main Window consists of the list of variables, menu, toolbar and status bar.

Main Work Space

The main workspace displays the Variable Name and Label and Check Mark Box indicating whether a variable
has been selected (tagged) for further action.  You can use the mouse and keyboard (PgUp/PgDn) to navigate
through the variable list. The color of the variable name and label indicates the variable type:

Color Type
Red Alpha
Green Categorical
Blue Continuous

File Menu

The File menu indicates the commands used to create output files, import tag file, and change the system
setup.
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Move Menu

You can navigate through the variable list displayed in the main workspace using commands from the Move
menu.

Tag Menu

You can tag or untag currently selected variables and navigate through the tagged items using commands
from the Tag menu.

View Menu

You can view the description of the currently selected variable or view tagged items using commands from the
View menu.

Search Menu

You can search for text string in variable names, labels and descriptions.

Toolbar
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The toolbar provides quick access to functions from the File, Move, Tag, and View Menu and to the Search
Command.

Status Bar

When you select a command from a menu, a description of the menu item is displayed in the message area.
The total number of variables currently tagged is displayed in the right corner of the status bar.
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How to View Tagged Variables

To view a list of tagged variables, choose the Tagged Items command from the view menu, or click on button.
If any items are tagged, a dialog box listing the items appears.

Click on the OK button to return to the main window.
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How to Search for Text

Choose the search command from the main menu, or click on the  button to search for specified text.

Dialog Box Options

Find What
Text to be found.  You may enter text or click on the down arrow to the right and choose from the list displayed.
The list displays text string previously entered, if any.  All text comparisons are UPPER case as are all text
entries.

Search From
Sets the area(s) to be searched.  The four possible areas are variable name (8 character SAS or SPSS
variable name), variable label, variable description (as displayed in the description window), and category label
(as displayed in the frequency window).

Search Next
Starts the search and stops at the first match with the FIND WHAT text.

Tag All Match
Starts the search.  When a match with the FIND WHAT text is found, the variable is tagged.  The search action
continues until there are no more matches.

Whole Words
Finds occurrences of the FIND WHAT text that is whole words, and not part of a larger word.

Direction
Sets the direction of the search—forward toward the end of the list or backward toward the beginning of the
list.  The search always starts from the current location of the cursor (black rectangle outlining current
variable).

Cancel Search
Cancels the search.

Close
Closes the search dialogs box and returns the user to the main work area.
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How to Tag/Untag a Variable

To Tag a Variable:

There are 3 ways to tag an untagged variable.  You can:

1. Position the mouse arrow on the tag box to the left of the variable name and click the left mouse button.

OR
2. Use the up or down cursor key to position the black rectangle over the variable and choose the Tag Item
command from the Tag menu.

OR
3. Use the up or down cursor key to position the black rectangle over the variable and press the "T" key.

When a variable has been successfully tagged,  appears in the  column.

To Untag a Variable:

There are 3 ways to untag a tagged variable.  You can:

1. Position the mouse arrow on the tag box to the left of the variable name and click the left mouse button.

OR
2. Use the up and down cursor key to position the black rectangle over the variable and choose the Untag
Item command from the Tag menu.

OR
3. Use the up and down cursor key to position the black rectangle over the variable and press the "T" key.

When a variable has been successfully untagged,  appears in the  column.

To tag or untag a range of variables:

You can also tag or untag a range of variables by using the standard Windows click then SHIFT-CLICK
procedure. (Tag or untag the first variable in the range, then position the mouse arrow on the tag box of the
last variable and click the left mouse button while pressing the SHIFT key.)

To clear all tags:

Select Clear All Tag from the Tag menu.
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How to View Descriptions/Frequencies

There are two ways to display variable descriptions/frequencies:

1. Position the mouse arrow on the variable of interest and double click the left mouse button.

2. Use the up or down cursor key to position the black box over the variable entry and choose Description
from the View menu.

You can toggle between the description and frequency for the selected variable by clicking on the View
Frequency or View Description button in the Description/Frequency window.

You can open up to two description windows for two variables displayed simultaneously by repeating either the
above steps.  You can move description windows using the standard Windows click-and-drag.

If you click on the  button in the Description window, this button will be changed to .  The  button
prevents this window from displaying the description of another variable; it fixes the display in the window.  If
you choose to view the description of another variable, it will be displayed only in the description window with
the  button.
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How to Navigate Through Variables

You can move between sections, files and tagged items.

 To move to the next section
Choose the Next Section command from the Move menu.

Or, click on  button.

To move to the previous section
Choose the Previous Section command from the Move menu.

Or, click on  button.

To move to the next file
Choose the Next File command from the Move menu.

Or, click on  button.

To move to the previous file
Choose the Previous File command from the Move menu.

Or, click on  button.

To move to the top of the list
Choose the Top List command from the Move menu.

Or, click on  button.

To move to the bottom of the list
Choose the Bottom List command from the Move menu.

Or, click on  button.

To move to the next tagged item
Choose the Next Tag command from the Tag menu.

Or, click on  button.

To move to the previous tagged item
Choose the Previous Tag command from the Tag menu.

Or, click on  button.
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How to Create SAS/SPSS Program Code, Codebook Text, Tag and
Access Database Files

From the File.Output menu:

1. To create SAS-PC program code, select the SAS-PC command.
To create an SPSS for Windows include file, select the SPSS command.
To create a Codebook text file, select the Codebook Text command.
To save current tags into a file, select the Tag File command.
To save current tags into Microsoft Access file, select the Access DB command.

2. A standard Windows directory dialog box appears, permitting you to specify the directory and file name for
the output file.

3.a) If you are creating a Codebook text file or a Tag file, click on the OK that pops up to start file generation.
   b) If you are creating a SAS-PC Code, SPSS file, the following confirmation dialog box pops up:

* Codes for ALPHA variables are to be included only if each code is recorded with single quote.

All Button
Creates code with value labels or PROC FORMATs for ALL values of ALL tagged variables, continuous and
categorical.

Categorical Button
Creates code with value labels or PROC FORMATs for ALL values of ALL tagged categorical variables.  No
code for tagged continuous variables is created.

None Button
Creates code with value labels or PROC FORMATs for non-reserved values of categorical tagged variables.
(Reserved values are enclosed with braces {..}.)

Cancel Button
Cancels output creation.
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Codebook text
For a printable text file that displays ALL information about tagged variables, select the Codebook text option.
For each variable, information on frequencies, labeling and file positions, and descriptive information is written
to the text (*.TXT) file.  In addition, the codebook text file may be used as input for the EXTRACT utility.

Access Database
The system creates a collection of text files delimited with commas and double quotes, which you can import
these text files into the Access Database.  The maximum number of variables in an Access table is 255.  If the
user selects more than 255 variables in one file, the system will create multiple text files for which file name is
changed by attaching extra character (i.e. a,b,c..)

To import the text files:
1. Start the Microsoft Access.
2. Open the database that was saved earlier by ECBW.  Or, you can create a new database if you wish.
3. Select the text files to be imported.

- Choose the File/Get External Data/Import menu.
- Select *.txt for ’Files of Type’.
- Double click on the text file you wish to import.

4. Choose the format - Delimited.  Then click on Next button.
5. Mark ’First Row Contains Field Name’ check box.
6. Check ’text Qualifier’ from ’(none)’ to ", then click on the Next button.
7. Mark ’In a New Table’, then click on Next button.
8. Skip to the next step by clicking on the Next button.
9. Mark ’No Primary Key’ and click on the Next button.
10. Click on the "Finish" button.

Repeat step 3 through step 10 as many as necessary until you have imported all the text files.

View Output
The View Output option on the File menu allows modification and printing of SAS/SPSS code or codebook
text files using NOTEPAD.
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How to Import Tag Files

Choose the Import Tag Files command from the File Menu.  The Import Tag Files window appears, prompting
you to enter the name of the files to be imported.

Dialog Box Options

File #1
The name of the first file of tags to be imported.  To enter the file name, click on the Browse button to the right
of File #.  The Windows’s standard directory dialog box that pops up allows you to select the desired file from
the directory.  Click on the OK button to return to the Import Tag Files window.

File #2
The name of the second file to be imported.  You do NOT need to specify File #2 if you wish to import only one
file of tags. To enter a file name, click the Browse button to the right of File #2. The Windows’s standard
directory dialog box that pops up allows you to select the desired file from the directory.  Click on the OK button
to return to the Import Tag Files window.

And
Tags only items tagged in both file #1 and file #2.

Or
Tags all items tagged in either file #1 or file #2.

Import
Starts the import tags process.
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How to Change the System Setup

Choose the Setup command from the File menu.

Dialog Box Options

Resource Directory
The name of the directory where the ECB resource files (*.cdc files) are located.  The ECB requires these files
to operate properly.  See System Requirements for detail.

To change the directory, click on the Browse button to the right.  The Windows standard directory dialog box
that pops up allows you to choose the directory you want.  Click on the OK button to return to the Setup
window.  Since the resource directory field is read only, you can change the directory only by using the
browse button.

Output Directory
The name of the directory for storage of all output files (e.g. SAS and SPSS code files). To change the
directory, click on the Browse button to the right.  The Windows standard directory dialog box that pops up
allows you to choose the directory you want.  Click on the OK button to return to the Setup window.  Since the
output directory field is read only, you can change the directory only by using the browse button.

CD-ROM Drive
The name of the CD-ROM drive.  To change the drive letter, click on the down arrow and choose the drive
from the list.

OK
Saves the new directories into the setup file and returns the user to the main work space.

Cancel
Cancels the data entered and returns the user to the main workspace.
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System Requirements

To operate the Electronic Codebook properly, you must have ECBW.EXE, 3 resource data files and a setup
file.  The project ID determines the names of the data files and the setup file.  The project ID is an abbreviation
of the full project name and is exactly 3 characters long.

For example, if the full project name is "National Longitudinal Study of the High School Class of 1972", the
project ID is "NLS."  Resource file names for this project are "ECBSPEC.NLS," "NLS01.CDC," and
"NLS02.CDC."  The setup file name is "NLSECB.CFG."

To Start the ECB
Click on the appropriate icon from the ECB group.

Or, if the icon is not available, choose the Run command from the WIndows95’s startup menu.  Then type
"ECBW P=project id" and click on OK.  For example, to run ECBW for NLS, type "ECBW P=NLS".

Note: There must be a space between ECBW and P=NLS.
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